Memory Zipper Plus

© Systweak 2000-2001.

RAM Performance Optimizer and Resource Monitor

Help File and Instructions

Mainpage

Operation and Instructions

Optimize

Tuning Windows

Configuration

CPU Cooler

Squeeze Ram

Task Manager

Optimize Swap File

About

systweak WebSite

Welcome to Memory Zipper Plus, the memory optimization and management tool. Memory Zipper Plus optimizes the windows memory management and the performance of your PC under Windows 95, 98, ME and Windows NT / 2000 / XP. You can optimize the memory of your PC just by oneclick or automatically. It is combinatin of tools and comes with Task Manger and CPU COOLER. It consumes negligible and Resources.

Windows (95/98/ME /NT/2000/XP) is a Modern operating system and supports Virtual Memory. In windows environment there are two types of memory :

1. System Physical Memory - It is the current installed RAM on a system. On modern systems it could range from 128 MB to 512 MB on Servers.

2. Virtual Memory - Windows create a Swap file on disk. Windows when run out of RAM saves Physical memory contents to this swap file. This Swap file is known as Virtual Memory. Whatever amount of RAM you have windows will always use virtual memory.

Windows memory management system can use both Physical and Virtual Memory. As soon as you run out of RAM windows starts to swap the data from physical memory to disk to make room. Thus you could run much more applications than your physical memory. But this system is not fool proof and some times some of program resources are on disk and others in memory or scattered all over. This results in memory leaks, program crashes, blue screens and disk activity after each and every task.

I have 256 MB RAM a Fast hard disk-

Bill Gates once said 640 KB (YES IT IS KILO BYTES) is ought to be more than enough for every one!! RAM is never enough. Windows will always use Virtual Memory even if you have a Giga Byte Memory.

You have feeled and noticed several times that windows after running for an hour starts to slow down. Menus popups like curtain and a disk activity follows after each and every task. Program loading starts to slow down. This is because of windows poor memory management & memory leaks which could bring even the fastest daemons to their knees.

What now?

You may close some Applications, but most often this will not fix the problem, As Windows does not reorganize the RAM totally. Parts of those programmes will stay in memory.

You may reboot your machine or re-start Windows. That means: save all your work, close all programmes, rebooting, restart Windows, restart all programmes, reload all your files and after a couple of minutes you got the same problem: NOT ENOUGH MEMORY !!!

You can use MEMORY ZIPPER PLUS!!!

Some examples of windows poor memory management

1. When a program allocates and frees memory, Windows does not frees the same amount as allocated. Even when the program terminates. Resulting in unnecessary blockage of memory.

2. Windows does poor synchronization between Virtual Memory and System Memory. Resulting in excess usage of Virtual Memory and unnecessary swapping to disk. (It is a modern operating system).

3. Windows keeps swapping Data from physical memory to disk and from disk to physical memory. Disk access is many times slower than Physical Memory. Thus many times you see your Hard Disk doing lot of work while switching windows.

4. Windows does not defrag the memory. Even if you may have free memory but not a large chunk, then windows will start using Virtual Memory. Thus again your performance will slow down.

5. Windows does not repair memory leaks thus resulting in crashes.

Memory Zipper Plus Features

(c) systweak

It frees the memory which windows neglects and fails to release. There is continuous supply of RAM which increases overall system speed.

It defrags the RAM and makes available a large block of memory to system. It reorganizes the Windows Swap File. Thus layout in memory matches perfectly with that of swap file and it increases the CPU L1/L2 cache hits. Thus you gain pure performance.

It optimizes your RAM and makes sure, that you can use as much RAM as possible for your daily work.

It repairs the memory leaks and avoids crashes, Blue Screens and unnecessary slow downs.

It comes with CPU Cooler to save power. Thus it will cool the cpu in the idle time.

It unloads unused DLL's from the memory to save resources.

It fully integrates within windows and makes the continuous supply of the resources to always-hungry programs.

It comes with Cache Tunning Features so that you may optimize the way windows uses the RAM. This not only result in efficient use of RAM, but faster disk access, faster program access and fully efficient windows memory management.

It increases the uptime of windows systems from few hours to weeks. Thus you could have your server continuously running for weeks not days.

This program has very small footprint in the memory and does not consume any precious resources. It walks away from the fancy interface to give you core performance without using much resources. Its Kernel is written in assembly language for speed and size. It does not have any VXD's or system services to slow down your system. It runs in low priority and does it's work in background.

It is fully customizable to suit your needs. It comes with auto optimization features. Reorganize your RAM after every few minute to auto protection.

It comes with a task manager to remove unused tasks and also lets you to set their priorities.

It also have option to tune the NT workstation.

Memory Zipper Plus solves the windows memory management and is optimized for small systems with 16 MB Ram to 512 MB servers.

loads applications up to 30% faster

It can be started with windows to do it's work since startup.

It does not consume precious Task Bar Space and sits in System Tray.

You have full control over the program or enable the auto settings for best optimizations.

Memory Zipper Plus works in background. But still you have a full control on it. Just right click on it at taskbar and you could optimize the Memory at a click , have a feel of it User interface. It uses very little resources in the background and while continuously monitoring the leaks and repairing them automatically.


How to use Memory Zipper Plus

How to use Memory Zipper Plus - Optimize TAB

Memory Zipper Plus is very simple to use. All the buttons have tooltips. Memory Zipper Plus interface is divided into various tabs.

Here you can free the Memory and have various information on your memory. To optimize RAM just adjust the slider in Memory Optimization Settings and press Optimize Button and Memory Zipper Plus will do the rest. Memory Zipper Plus comes with the protection to enable you to Free right amout of RAM.

Here you can adjust how much memory to Free. But it is recommneded that you keep the Slider in middle. Freeing to much RAM to often can sometimes slow your system.

Memory Zipper Plus comes with full graphical representation of your memory. The above Graph is your memory life line. It will show the Memory activity. Thus you can see the memory used by a program and whether it manages the memory efficiently. To have a correct picture always set the Histogram Update Frequency Slider to lowest. Then you will see the correct position of your System Memory.

The Right side Shows Four Bar Graphs

mzp1rs.GIF (6876 bytes) 1. System Memory Free - It Shows Current System RAM. If it is to Red You are using Ram. On a system with RAM between 64 MB and 128 MB it should be about 60% to 72%. If too Red it is a time to Optimize. The more green it is the more healthier your PC.

2. Virtual Memory Free - It shows the Ram windows use as a swap file (read more about swap file) . Too much usage about 50% will slow down your system.

3. Total System Index - It shows the total index based on above two.

4. CPU Usage - Memory Zipper Plus also shows CPU Usage. It comes with a CPU cooler. (read more about CPU usage and CPU Cooler).

All the rest shows the above figures in text.

Buttons What do they do

optimize_but.GIF (6171 bytes)

  • Optimize - It will optimize your Memory. It will free the Ram Your aplications Need.
  • Squeeze Ram - It will squeeze every byte from your Memory. Read More about Squeeze Ram from Here.
  • Task Manager - It will Start Memroy Zipper Plus Task Manager. Read More Baout Task Manager from Here.
  • Minimize - Hides the Memory Zipper Plus.
  • Exit - Exit Memroy Zipper Plus.

<<Home Next (Tuning Windows) >>

(c) systweak 2000-2001.


How to use Memory Zipper Plus

How to use Memory Zipper Plus - Tune Windows.

Memory Zipper Plus behaves diffrently when run in Windows 95/98/ME and int Windows NT/2000/XP. It shows diffrent options to tune Windows.

Windows 95/98/ME - Tweak Memory.

Windows NT/2000/XP - Tune Windows.

Tweak Memory TAB - Windows 95/98/ME

Here you can adjust the VCache settings. VCache is very important for windows 95/98 and ME. Windows NT/2000 manages the cache automatically. If the cache settings are not specified then windows will end up using the entire memory for cache and start using the virtual memory. It will not only degrade the performance but will also result in crashes.

For most efficiency both minimum and maximum cache should be of same size. The should be in the range of 1/8 to 1/6 of physicl memory. VCache should not exceed 32 MB as more cache will also degrade the performance.

Chunk size is the Block size in which windows manages the cache. If larger block size s specified more data will be stored in the blocks but there will be fewer blocks. If too much small size is specified there will be larger blocks with data scattered all over. So for most efficiency Chunk size should be in the range of 512 to 4096 bytes.

Tune Windows TAB - Windows NT/2000/XP

 mzp2.GIF (21868 bytes)

On Windows NT/2000/XP Memory Zipper shows different settings. Lets summarize them.

Memory and System Performance

  1. Large System Cache : This setting tells the OS to devote all but 4 MB of system memory (which is left for disk caching) to the file system cache. The main effect of this is allowing the computer to cache the OS Kernel to memory, making the OS more responsive. The setting is dynamic and if more than 4 MB is needed from the disk cache for some reason, the space will be released to it. By default, 8MB is earmarked for this purpose. This tweak usually makes the OS more responsive. It is a dynamic setting, and the kernel will give up any space deemed necessary for another application (at a performance hit when such changes are needed). Recommended on System with 128 MB or more.
  2. Improve Core Kernel Performance : By this tweak Windows will keep its kernel in System Memory rather than swapping it to disk. It will improve your NT performance. Recommended on System with 64 MB or more.
  3. CPU Cache : Now many cpu comes with different cache. Some comes with 128 K to 512K. Windows by default assumes 256K. Specifying correct size improves performance. on intel based system it is
CPU | Cache
P-II 233 MHz to 450MHz | 512 KB
P-III upto 550 MHz | 512 KB
Celerons - 300 MHz and Above | 128 KB
P-III above 650 MHz | 256 KB

For Xeon and AMD based CPU consult your manual.

  4. Windows Cache - It specifies Memory Windows can use for IO operations. It should be about 1/2 od system Memory. on System below 128 MB RAM it should be 1/4 of System Ram.

Optimize for Speed and Optimize for Minimum Memory - This will tweak system respectively. But for system with 128 MB RAM or more use optimize for speed.

File System Tweaks

1. Disable Time Last access - On NTFS systems while browsing for directories or searching for files can be painful. As windows will coninously be updating Time Stamps. It will slow down a system with each read or write. Recommeded ON.

2. Disable 8.3 File Names - It will disable creating 8.3 old short file names on NTFS volumes. It could improve performance. If you do not use old DOS applications then enable this tweak. If you use old dos apllications and when you enable this tweak any new filename you have created will not be accessible in that DOS. Recommended ON.

Visual Effects - They could slow down system. Even a speedier Processor could feel like doing nothing. They also waste time while drawing such effects. Recommended Disable Visual Effects.

<<Home Optimize Tab Memory Zipper Plus Configuration>>

(c) systweak 2000-2001


How to use Memory Zipper Plus

How to use Memory Zipper Plus - The Configuration

Here you can adjust the way Memory Zipper Plus Works.

Memory Zipper plus is fully customizable. Here in above screen shot shows the configuration screen of Memory Zipper Plus. You can customize any or all aspect here.

mzpoptions1.GIF (1184 bytes) Show Optimization Progress - While optimizing Memory Zipper Plus will show optimization Progress. Not Recommended. It could sometimes be disturbing.

Clear Clipboard While Optimizing - Not recomneded. But it could free Memory.

Update Graph.. - Update the chart when Memory Zipper Plus is Minimized. It will update frequently. If off It will be less frequently updated.

mzpoptions2.GIF (4577 bytes) Auto Optimize Interval Frequency - Memory Zipper Plus will start optimization after specified time.Recommended 25 Minutes. 'Auto Optimize Every' checkbok should be set on.

Auto Optimize System Memory - Memory Zipper Plus will optimize Memory when it fell below Level. Recommended 8 MB on system with 64 MB or less. 'Free Ram on Alarm Level' should be on.

mzpoptionssld.GIF (2034 bytes) It Specifies how much interval Memory Zipper Plus will update. Recomeded Slow. It will consume least CPU resources and will show real picture.

mzpoptionscpu.GIF (915 bytes) Memory Zipper Plus Comes with CPU Cooler. You can here start CPU Cooler. (more on cpu....)

Run in Low Priority - Memory Zipper Plus configure itself to utilize least CPU resources.

Other option specifies whether to load on Start up. Memory Zipper should be loaded on startup.

Memory Zipper Plus - System Information

mzp4.GIF (19795 bytes)

You can check here some small details about your CPU.

<< Home Memory Zipper Plus Configuration About>>

(c) systweak 2000-2001.


Memory Zipper Plus -CPU

CPU COOLER

Memory Zipper is the only tool in its catagory that comes with the CPU Cooler.

CPU Cooler cools the CPU. It will take CPU in the power saving mode for few mili seconds. It will not harm any performance because CPUs are designed to wake up soon. Besides CPU Cooler runs in the least priority. That means windows will call CPU cooler when it is idle and doing nothing. Most of the time CPU is idle and waiting for instructions to process about 90% idle time. CPU cooler just utilizes this idle time and cools CPU to save power. Infact it will give boost to applications as Cool CPU will perform well.

Sometimes you will notice that CPU usage shows 100% while CPU cooler is running. It is because CPU usage is calculated on CPU idle time and CPU cooler utilizes that idle time. No need to worry about it.

Since Memory Zipper Plus comes with a CPU Cooler so do not install and use other CPU coolers.

Currently CPU Cooler works on Windows 95/98/ME. Work is in progress for CPU cooler in windows NT/2000/XP.

<<HOME>>


How to use Memory Zipper Plus

Swap File

Windows (95/98/ME /NT/2000/XP) is a Modern operating system and supports Virtual Memory. In windows environment there are two types of memory :

1. System Physical Memory - It is the current installed RAM on a system. On modern systems it could range from 128 MB to 2 GB on Servers.

2. Virtual Memory - Windows create a Swap file on disk. Windows when run out of RAM saves Physical memory contents to this swap file. This Swap file is known as Virtual Memory. Whatever amount of RAM you have windows will always use virtual memory.

Windows memory management system can use both Physical and Virtual Memory. As soon as you run out of RAM windows starts to swap the data from physical memory to disk to make room. Thus you could run much more applications than your physical memory. But this system is not fool proof and some times some of program resources are on disk and others in memory or scattered all over. This results in memory leaks, program crashes, blue screens and disk activity after each and every task.

swap1.GIF (4902 bytes) To adjust your swap files first right click my computer on the desptop and select propoerties.

You will then see this box. It is simmilar.

sysprop98.GIF (10088 bytes)

On windows NT it is simmillar. Just Goto performance in NT.

swapnt1.GIF (10513 bytes) In 2000/XP Goto Advance as shown in figure

Now goto Performance and set the swap file. Do set a fixed swap file of 256 MB both min and max.

In NT/2000/XP you can set swap file on many partitions. If you have more disk create a swap file 96 MB bot min and max on each disk. It will improve the performance.

<< home >>


Memory Zipper Plus - Task Manager

Memory Zipper Plus - Task Manager

TaskMan.GIF (14720 bytes)

Memory Zipper Plus Comes with a task Manager. Here you can kill tasks which CTRL-ALT-DEL list (windows 95/98/ME) does not show and can also set there priorities.

Memory Zipper Plus comes with the protection, so it will not show System Tasks and Processes. So you can't change system processes, you can only change the user applications.

Process Priorities :

Idle Priority - This is the lowest priority. Programs with such priority are given CPU time last after higer priorities. But since CPU is idle most of the time such tasks gets the idle time. CPU intesive tasks and any background process should be run in such priority. It is the safest and my favorite priority.

Normal Priority - Most applications run under this priority. No scheduling needs are there and applications get Normal CPU time. Processes running under this have Priority over Idle Priority class. It is also Safe Priority.

High Priority - It is most suitable for applications that require immediate attention. They get much more CPU time than any other priority class. It is not recommeded for CPU intensive programs as system might hang. It is a dangerous priority. If you want that any task should get more CPU time set it to idle priority.

Realtime Priority - It is reserved for system and Memory Zipper Plus will never allow you to set this priority.

Windows 2000/XP have more Priorities.

Below Normal Priority : It is between Idle and Normal priority. It is also the safest priority. Keep CPU intensive tasks under this priority. So other process can also get CPU time.

Above Normal Priority : It is between High and Normal Priority. Recommended for task that require immediate attention. Not recommended for CPU intensive tasks.

<<home>>


Memory Zipper Plus - Squeeze Ram

Squeeze Ram

Sometimes single optimization is not enough. Memory Zipper Plus comes with a Squeeze Ram feature. It will squeeze as much ram it from System.Squuezing too much could RAM could slow down the system so Memory Zipper comes with option for how much time squueze ram should work.

mzp_sqz1.GIF (13277 bytes)

If you do not set it within 20 seconds Memory Zipper Automatically starts to optimize. The recommneded setting is two passes.

Here are some screenshots of all the passes.

mzp_sqz2.GIF (16770 bytes) Pass One

mzp_sqz3.GIF (16632 bytes) Pass two

mzp_sqz4.GIF (16386 bytes) Pass Three

After all Squezee operations Memory Zipper Plus will show summary of opearation.

<<Home>>


About Memory ZIpper Plus

About

Memory Zipper Plus is developed and owned by Systweak Corporation. For more information and support you may contact at srana@systweak.com or just visit the Web Site http://www.systweak.com.

Memory Zipper Plus is shareware. Do register your copy.

Memory Zipper Costs US$ 19.95 but for limited time register it for half price US$ 9.95.

From here you may register online at secure server :

https://secure.element5.com/register.html?productid=138163

We also accept orders via email at: register@shareit.com

If you are not yet on-line, you can place your order with our customer service team by phone, fax or postal mail.

ShareIt!
element 5 AG
Vogelsanger Str. 78
50823 Cologne
Germany

Phone: +49-221-2407279
Fax: +49-221-2407278
E-Mail: register@shareit.com

US and Canadian customers may also order by calling toll-free 1-800-903-4152. This hotline is only for ordering.

On registration you will receive the Registered version with future upgrades free. Also you will receive a special CORE version completely written in ASM for speed and size.

<<Home>>

© Systweak 2000-2001.


systweak.com

Please Click Here to visit

http://www.systweak.com